SQL Developer is returning only the date, not the time. How do I fix this ?

SQL Developer is returning only the date, not the time. How do I fix this ?

Asked on December 14, 2018 in SQL Server.
Add Comment


  • 5 Answer(s)

    Follow the below procedure,

    First go to Tools and then drive into  Preferences  then Database and then  NLS and set the Date Format as MM/DD/YYYY HH24:MI:SS

    Answered on December 14, 2018.
    Add Comment

    Using this code you can set the Date format.

     

    Then SESSION set as NLS_DATE_FORMAT = ‘date_format’

     

    example:

    alter SESSION set NLS_DATE_FORMAT = ‘DD-MM-YYYY HH24:MI:SS’

    Answered on December 14, 2018.
    Add Comment

    Go to this path,

    Initially, Tools > Preferences > Database > NSL Parameter and finally set the Date format as

    DD-MON-RR HH:MI:SS

    Answered on December 14, 2018.
    Add Comment
    select
      to_char(CREATION_TIME,'RRRR') year, 
      to_char(CREATION_TIME,'MM') MONTH, 
      to_char(CREATION_TIME,'DD') DAY, 
      to_char(CREATION_TIME,'HH:MM:SS') TIME,
      sum(bytes) Bytes 
    from 
      v$datafile 
    group by 
      to_char(CREATION_TIME,'RRRR'), 
      to_char(CREATION_TIME,'MM'), 
      to_char(CREATION_TIME,'DD'), 
      to_char(CREATION_TIME,'HH:MM:SS') 
     ORDER BY 1, 2; 
    
    Answered on January 14, 2019.
    Add Comment

    First go to Tools and then drive into  Preferences  then Database and then  NLS and set the Date Format as —  MM/DD/YYYY HH24:MI:SS

    Answered on January 14, 2019.
    Add Comment


  • Your Answer

    By posting your answer, you agree to the privacy policy and terms of service.